Can't log in to facebook

timdp21's Avatar

timdp21

04 Oct, 2011 07:38 AM

I can not for the life of me get logged into Facebook. It used to work with no problems but now i have no idea how to get it to work.

  1. 2 Posted by timdp21 on 04 Oct, 2011 07:45 AM

    timdp21's Avatar

    To continue that... I get to the FB log in screen. I enter my account information, I name the device, and I am back to the log in screen again.

    What is going on?

  2. Support Staff 3 Posted by Scott Werndorfer on 05 Oct, 2011 11:44 AM

    Scott Werndorfer's Avatar

    What version of Trillian are you using?

  3. 4 Posted by Christopher on 05 Oct, 2011 12:07 PM

    Christopher's Avatar

    I have a similar problem with Trillian for Web from my "work" pc:
    Every try to log in to the Facebook chat gives me a small "speech buble" reading "Unknown Translation" (Screenshot added). When I klick on the Message I am shown a message that a Login with Facebook is required (Screenshot added too).
    System: Windows 7 Enterprise, Firefox 6.0.2. All other chats run properly (ICQ, Microsfot Live, Astra). It could just be the old Version of Firefox.

    When I log at my computer at home, Facebook login runs without problems (at least not more than normal).

  4. Support Staff 5 Posted by Scott Werndorfer on 05 Oct, 2011 12:14 PM

    Scott Werndorfer's Avatar

    And what happens when you press "Connect with Facebook"?

  5. 6 Posted by Christopher on 05 Oct, 2011 02:06 PM

    Christopher's Avatar

    This error occurs whenever Trillain Web tries to access the Facebook chat.
    It happens right after login to trillian web (the autoconnect) as well as any manual try to switch Facebook chat to Online.

    And now I checked it at home too:
    Same problem, same message. Even when Trillian for Windows is connected to the chat at the same time, Trillian for Web just says: "Unknown Translation" whenever I try to login to Facebook chat.
    This time with Windows 7 Home Premium and Firefox 7.0.1

  6. Support Staff 7 Posted by Scott Werndorfer on 05 Oct, 2011 05:46 PM

    Scott Werndorfer's Avatar

    You're supposed to be able to click the blue 'connect with facebook' button. What happens when you do this? You should be brought to a Facebook login page and be able to enter your username and password.

  7. 8 Posted by Christopher on 05 Oct, 2011 08:23 PM

    Christopher's Avatar

    I think my problem could be in the wrong section. It's a problem with the Trillian for Web under Windows/Firefox. I had only read "can't log into facebook" without reading what Subforum it is in.

    I try to give you a desciption of the situation as detailed as possible:
    All of the stuff below asumes a 32-bit OS and 32-bit software.

    1) Trillian for Windows 5.0 Build 35 free of charge; August 19th 2011
    Is correctly loged in and displaying both the facebook chat and the facebook newsfeed. I can chat until the keyboard smokes.

    1b)I exit Trillian for Windows 5.0.

    2)I go to http://www.trillian.im/chat/ (with Firefox 7.0.1 + Flash Player 11.0.1.152) and log in with my Trillian Account

    2b) Astra, ICQ and MS Live Messenger are logged in automatically.
    I am not logged in into Facebook chat. One Message "Unknow Translation!" is showing (as seen in my first post).

    2c) I try to manually Log into Facebook chat using the symbol for the chat.
    Imediately another "Unknow Translation!" bubble appears above the other (I tried this until I got two rows of them, see attached file). The icon for Facebook changes shortly but goes back to disconnected after the error appers. So I guess the Click Event for "Connect to Facebook" is fired and processed.

    3) I click on the Text, get directed to the second page from my first post, I fill out the Facebook Login page and am connected to Facebook Chat for the moment.

    4) Trying to either reconnect to facebook (disconnect + connect) or starting a new instance of Trillian for Web gives the behavior under 2b again.

    5) I sign out of Trillian for Web and close the browser.

    6) I start Trillian for Windows again.

    6b) Trillian for Windows has correctly connected to all my chats (inlcuding Facebook) and the Facebook Newsfeed despite all the problems the Trillian for Web has.

    As a Programmer my best guess is:
    Something goes wrong between retrieving the Facebook username/password or token from the Trillian Server and before saving it in the running instance of Trillian Web. Apparently entering the account information gives a valid facebook-chat-login token that gets saved and used correctly.
    But whatever Trillian for Web transmits during a atempt to login to facebook is != what Trillian for Windows transmits during the exaclty same action (if it even tries and doesn't falls over some Exception before ever sending anything).

    What I could do:
    The best Idea I have is to have a wireshark running to see if username/password are evens sent to the facebook servers as well as intercepting the message. But with all the stuff windows/my browser sends I need to know what Filter options to use (i.e. what protocolls are used, what the Name/IP adress of the Facebook Login servers will be). I could even try to do this in a Virtual Machine to have a clean environment.

  8. Support Staff 9 Posted by Scott Werndorfer on 06 Oct, 2011 01:25 PM

    Scott Werndorfer's Avatar

    OK, so to be clear, you're able to connect to Facebook chat but only ONCE per session, and each time you're forced to re-authorize.

    The Unknown Translation should actually read: "Trillian needs your permission to connect to Facebook Chat" or something along those lines. I'll jot this down and get it fixed. I think we know why this is happening, we need to do some upgrades to the Trillian for Web product to adhere better to some of the new Facebook authentication requirements. We're hoping to get this finished in the next few weeks, at which point the problem should be resolved. Thanks for bringing it to our attention!

  9. 10 Posted by Serene on 09 Oct, 2011 07:34 PM

    Serene's Avatar

    This comment was split into a new discussion: Can't log in to facebook

    I can't log into Facebook from Trillian anymore from my PC. And when i could I couldn't activitate chat. When I try I get a window that says that a browser will open and to click when permission granted. All the browser says is An error occurred with Trillian. Please try again later. Feel like it's circular. I've changed my password, shut Trillian down and rebooted it, logged in and out of FB. Where do I go from here?

  10. 11 Posted by Matt on 11 Oct, 2011 01:13 PM

    Matt's Avatar

    Seems to be a Similar issue, so I'll put it here.

    Trillian was working fine on my laptop (Windows 7 64-bit) which is currently in getting repaired.
    On my desktop machine (Windows XP SP3 32-bit) I connect to facebook but the chat won't connect at all.

    So when I hover over the Facebook connection icon it says Online, but right click and hover on chat> and it shows the options Connect (or Reconnect if I've already tried) and Disconnected with a tick before it, or Disconnected (due to an error) with a tick before it.

    I've tried rebooting, re-entering my details and nothing. I'm not seeing an error message (so have no idea what the error it's disconnecting chat for is) and I have authorized it in facebook.

    Current version is TrillianAstra version 4.2 Build 27 Pro

    Trillian makes it so much nicer to use FB Chat than the web interface of the site and hope that this can be sorted out quickly and easily.

    Regards,
    Matt

  11. Support Staff 12 Posted by Scott Werndorfer on 11 Oct, 2011 02:19 PM

    Scott Werndorfer's Avatar

    Matt, try our latest version: http://www.trillian.im/get/windows/beta/ and see if it helps.

  12. 13 Posted by Matt on 11 Oct, 2011 03:52 PM

    Matt's Avatar

    Thanks Scott. Seems that the updater for 4.x doesn't update to 5.x which is what I had on my laptop. I recognised it as soon as it loaded and it works fine.

    Thanks for the help

    Matt

  13. Don Petty closed this discussion on 11 Oct, 2011 08:55 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac